Help

Bat To Exe Converter - Documentation

Index

1 - Program description

  1.1 Description
  1.2 Usage
  1.3 Options
  1.4 Commandline
  1.5 System requirements
  1.6 Programinfo

2 - License

  2.1 License
  2.2 Miscelleanous

3 - Contact

  3.1 Author
  3.2 Website
  3.3 Email

Description

Bat To Exe-Converter converts batch-script files to executable files

Usage

Select a batch file and the save path.
Customize your settings. Click on the button "Compile".
You can also use the commandline.

Options

Visible application
Create a visible application with a console window
Invisible application
Create an invisible application without a console window
Current directory
Use the current directory on execution
Temporary directory
Use the temporary directory on execution
Submit current directory
Submit the current directory as the last parameter
Delete at exit
Delete the temporary files at exit
Do not delete
Do not delete the temporary files
Encrypt the program
Encrypt the program with a password
Add Decompiler
Add a decompiler to the program
Administrador manifest
Add an administrador manifest to the program
Overwrite existing files
Overwrite existing files
Include
Include additional files to the program
Icon
Include an icon to the program
Versioninformations
Include versioninformations to the program

Commandline

Required parameters

-bat [filename]
Bat file to compile
-save [filename]
The savefilename of your application

Optional parameters

-icon [filename]
The icon file of your application
-invisible
Create an invisible application
-temp
Use the temporary directory on execution
-nodelete
Do not delete the temporary files
-encrypt [Password]
Encrypt the program with a password
-admin
Add an administrador manifest to the program
-overwrite
Overwrite existing files
-decompiler [String]
Add a decompiler to the program
-include [filename]
Include additional files to the program
-fileversion [String]
File version number
-productversion [String]
Product version number
-company [String]
Company name
-productname [String]
Product name
-internalname [String]
Internal name
-description [String]
Product description
-copyright [String]
Copyright

Example

Bat_To_Exe_Converter -bat mybatfile.bat -save myprogram.exe -icon myicon

System requirements

Windows 2000 or higher.

Programinfo

Name:
Version:
License:
Last modified:
Size:
Bat To Exe Converter
1.5.1.0
Freeware
2010-11-18
444 KB

License

License Agreement

Copyright (c) 2010 Fatih Kodak

Permission is hereby granted, free of charge, to any person obtaining a copy
of this software and associated documentation files (the "Software"), to deal
in the Software without restriction, including without limitation the rights
to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
copies of the Software, and to permit persons to whom the Software is
furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in
all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
THE SOFTWARE.

Miscelleanous

Bat To Exe Converter uses these following third party programs.

GoLink GoRC UPX

Contact

Website:

Email:

www.f2ko.de

webmaster@f2ko.de


Hilfe

Bat To Exe Converter - Dokumentation

Index

1 - Programmbeschreibung

  1.1 Beschreibung
  1.2 Verwendung
  1.3 Optionen
  1.4 Kommandozeile
  1.5 Systemvorraussetzungen
  1.6 Programminfo

2 - Lizenz

  2.1 Lizenz
  2.2 Sonstiges

3 - Kontakt

  3.1 Author
  3.2 Webseite
  3.3 Email

Beschreibung

Bat To Exe Converter wandelt Batch Script Dateien in Exe Dateien mit erweiterten Funktionen um.

Verwendung

Wählen Sie eine Bat Datei zum Öffnen und den Pfad zum Speichern aus.
Nehmen Sie Ihre gewünschten Einstellungen vor und klicken Sie anschliessend auf "Kompilieren".
Das Programm lässt sich zudem per Kommandozeile steuern.

Optionen

Sichtbares Programm
Erstellt ein sichtbares Programm mit einem Konsolefenster
Unsichtbares Programm
Erstellt ein unsichtbares Programm ohne Konsolefenster
Aktuelles Arbeitsverzeichnis
Führt das erstellte Programm im aktuellen Verzeichnis aus
Temporärer Ordner
Führt das erstellte Programm im Temp Verzeichnis aus
Arbeitsverzeichnis übermitteln
Übermittelt dem Programm das aktuelle Verzeichnis als letzten Parameter
Beim Beenden löschen
Löscht alle temporären Dateien am Ende der Ausführung
Nicht löschen
Löscht keine temporären Dateien
Programm verschlüsseln
Verschlüsselt das Programm mit einem Passwort
Decompiler hinzufügen
Fügt dem Programm einen Decompiler hinzu
Administrator Manifest
Fügt dem Programm ein Administrator Manifest hinzu
Dateien überschreiben
Überschreibt bereits vorhande Dateien
Einfügen
Fügt Dateien in das Programm ein
Icon
Bindet ein Icon in das Programm ein
Versionsinformationen
Bindet Versionsinformationen in das Programm ein

Kommandozeile

Benötigte Parameter

-bat [Dateiname]
Die zu kompilierende Bat Datei
-save [Dateiname]
Name zum speichern des Programmes

Optionale Parameter

-icon [Dateiname]
Name der Icondatei
-invisible
Erstellt eine unsichtbare Anwendung
-temp
Führt das erstellte Programm im Temp Verzeichnis aus
-nodelete
Löscht die temporären Dateien am Ende der Ausführung nicht
-encrypt [Passwort]
Verschlüsselt das Programm mit einem Passwort
-admin
Fügt dem Programm ein Administrator Manifest hinzu
-overwrite
Überschreibt bereits vorhande Dateien
-decompiler [String]
Fügt dem Programm einen Decompiler hinzu
-include [Dateiname]
Name der einzubindenen Datei
-fileversion [String]
Nummer der Dateiversion
-productversion [String]
Nummer der Produktversion
-company [String]
Name der Firma
-productname [String]
Name des Produktes
-internalname [String]
Interner Name des Produktes
-description [String]
Beschreibung des Produktes
-copyright [String]
Urheberrecht

Beispiel

Bat_To_Exe_Converter -bat mybatfile.bat -save myprogram.exe -icon myicon

Systemvorraussetzungen

Windows 2000 oder höher.

Programminfo

Name:
Version:
Lizenz:
Geändert am:
Größe:
Bat To Exe Converter
1.5.1.0
Freeware
18.11.10
444 KB

Lizenz (englischer Text)

License Agreement

Copyright (c) 2010 Fatih Kodak

Permission is hereby granted, free of charge, to any person obtaining a copy
of this software and associated documentation files (the "Software"), to deal
in the Software without restriction, including without limitation the rights
to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
copies of the Software, and to permit persons to whom the Software is
furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in
all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
THE SOFTWARE.

Sonstiges

Das Programm verwendet folgende Drittparteisoftware.

GoLink GoRC UPX

Kontakt

Webseite:

Email:

www.f2ko.de

webmaster@f2ko.de